There appears to have been a change on the software sometime not too long ago that is currently throwing the following error message in place of any information on database entries that don't specify control type:

Template Error

UndefinedVariable: u'control_type' is not defined

Near: [u'\n',

This hadn't been the case until recently as it was possible to leave the control type blank if unknown or not represented in the limited options provided and the information in the entry still visible, as would be expected since it's not specified as required information, but now hundreds of entries have been rendered useless by this glitch. The only way to fix it seems to be to go in and edit the page to force a control type, but for those aforementioned instances where the options do not fit or would only be guessed at it will only fill entries with misinformation.

Is this going to be fixed as it was before or at least have an option for "Other" or "Unknown" provided for? I'd rather not put the wrong information on an entry and mislead others just to make the software work like it had.

hey jpvanson, thanks for the heads up and sorry about this error. Can you link to an example gear that is throwing this error so we could fix it?

Thanks for looking into this. Here are a few examples I ran across just now in a quick search:

It's a bit inconsistent. Some that should be throwing a similar error, say as an example, aren't while others that had worked no longer are. That formerly working entries were throwing this error had me worried that there more I was not seeing and that more would follow given the consistency of the template error being thrown when the control type is not defined.

I seem to have fixed one of mine the other day thinking it a singular case by editing the control type, but as I mentioned before the options require knowing exactly what the control might be (not always the easiest to be certain from the user standpoint) or having controls that fit the limited options provided. Take the more recent Tannoys above as an example, their "controls" are set by knurled head thumb screws acting as jumpers. Changing that to, say, "rotary switch" would seem to fix the template issue, but it's nowhere near accurate and just deleting the controls altogether removes useful information about the treble levels and roll-off slopes. I just want to be accurate with what I put up here and not be lazy with my entries nor mislead others just to avoid a small database hiccup if I can help it.

Thanks for the links and detailed explanation jpvanson. Added a fix for displaying those gears. What was happening was that some of them were missing attributes that were required in the templates, now they should render without those errors if they attributes aren't defined.

Thank you.

Login or Register to post a reply to this topic.